Seting WAN untuk ADSL pada Huawei HG553 OpenWrt

Secara bawaan (default) firmware OpenWrt untuk Huawei HG553 konfigurasi WAN (ADSL khususnya), tidak otomatis disertakan, karena memang tidak ada port ethernet khusus untuk koneksi WAN. Maka kita bisa memanfaatkan switch-config untuk membuat Virtual LAN (vlan) dengan contoh di sini kita akan gunakan ‘port 4 (4/TV)’ sebagai koneksi ethernet untuk WAN yang akan terhubung dengan modem ADSL yang sudah diseting sebagai mode bridge. Firmware yang saya gunakan di sini adalah versi BarrierBreaker 14.07.

Cara Webbase

Buka browser pada PC/Laptop dan ketikkan IP address router kemudian login:

  1. Masuk ke menu Network –> Switch –> Add (VLAN), maka akan tercipta VLAN2.
  2. Pada baris VLAN1 kolom PORT3, rubah opsi menjadi Off.
  3. Pada baris VLAN2 kolom PORT3, rubah opsi menjadi Untagged dan kolom CPU menjadi Tagged.
  4. Kemudian klik Save & Apply.
    hg553-6
  5. Masuk ke menu Network –> Interface –> Add New Interface.
    hg553-7
  6. Isikan nama interface yang baru, misalnya: wan –> pilih protocol-nya PPPoE –> pilih VLAN Interface: “eth0.2” –> klik Submit.
    hg553-8
  7. Isikan Username dan Password dan klik Save & Apply.
    hg553-9
  8. Dan terakhir, port4 “4/TV” kita hubungkan dengan modem ADSL yang sudah diseting sebagai bridge.
Cara CLI

Akses router dengan SSH, lalu edit file /etc/config/network

  1. gatoti@bunglon:/> ssh root@192.168.1.6
    root@192.168.1.6’s password:
    root@owrt-hg553:/# cd /etc/config
    root@owrt-hg553:/etc/config# vi network
    config switch
    option name ‘eth0’
    option reset ‘1’
    option enable_vlan ‘1’config switch_vlan
    option device ‘eth0’
    option vlan ‘1’
    option ports ‘0 1 2 4 5t’ ##–> hapus angka 3 pada baris ini
    ##–> tambahkan baris script di bawah ini
    config switch_vlan
    option device ‘eth0’
    option vlan ‘2’
    option ports ‘3 5t’
  2. ##–> tambahkan juga baris script di bawah ini untuk konfigurasi WAN
    config interface ‘wan’
    option proto ‘pppoe’
    option ifname ‘eth0.2’
    option username ‘xxxxxxxxx’
    option password ‘xxxxxxxxx’

hg553-10hg553-11

Referensi:
http://wiki.openwrt.org/toh/huawei/hg553